Requirements

This section describes the requirements to install HELM.

Runtime requirements

For runtime operations, you need to install and set up either OpenNMS Horizon 29+ or Meridian 2021+. You also need a Grafana instance (version 8.0 or newer).

HELM 9.0.0-SNAPSHOT has been tested with Grafana versions up to 8.5. We recommend that you use matching versions of HELM and Grafana (for example, HELM 8.x and Grafana 8.x).

The OpenNMS Grafana Dashboard Report feature requires the Grafana Image Renderer plugin to be installed.

Build requirements

To build HELM, you must have Node.js installed (version 16.x or newer).

This is required only if you are installing HELM from source.