Requirements

Before installing ALEC, we assume that you already have an instance of OpenNMS Horizon 30.0.1 or greater up and running.

See OpenNMS Installation for help on getting started with OpenNMS.

We also recommend setting up OpenNMS Helm (requires 3.0.0 or greater) to view and manage the situations, as well as Elasticsearch (requires 6.3.0 or greater) to maintain event and alarm history for training purposes. The installation guide will assume that these are also set up.